professional antenna software

English | Russian | Deutsch | Manual | Help | Ordering and Contact |

System Requirements

 
  • Operating system MS Windows (XP, Vista, 7, 8).
  • RAM 1 GB min, recommended 8 GB. The maximum number of segments is dependant on the amount of free RAM. For calculation of 45000 segments 16 GB of free RAM is required.


Options


Installation

  • Unpack the ZIP file to a suitable directory and start file MMANAGALpro_setup.exe.
  • After installing and first start the Pro version software automatically opens a window Activate.  Enter in the this window your name and/or call and click the button E-mail activation request
  • Please send this request  to our e-mail. You will be sent a personal activation code within 24 hours during normal working days – Monday through to Friday.
  • To enter the received activation code, go to Main Menu -> Help -> Activate, and enter (by the button Paste personal activation code)  the activation code you received.
  • Press OK button. Restart program.
  • Once the code is entered, entered, the program will be fully functional, and the buttons  and will appear on toolbar, as shown in picture below:

    Absence of these buttons on the Tool-bar indicates the activation was not successful.

* Until the Pro version is activated, the program will still function as the basic version, i.e. without the extended capabilities of PRO version.


Screenshots

   The Pro version can handle very large numbers of elements, enabling the user to create very complex antenna models as can be seen in the following examples.

   These are a few examples of very complex antenna .maa files that are available in the program directory in the ANT_PRO folder. Use the control below to review the various examples.

Previous screenshot                          Auto scroll / Stop                           Next screenshot



File merging

   Up to 4 independent antenna model files can be merged in the PRO version.

   To merge a new antenna into an already open file, you will need to use the on the tool-bar,

    And then select the new antenna from one of the directories you are using. You can add other antennas as required (max 3 to the original one).

   After merging the individual antennas into a common file:

  • All the wires and loads of each of the antennas are taken into account during calculations.
  • However, any editing of the combined antenna model (move, rotate, edit wire, etc) has to be performed on individual antennas by first selecting the required antenna you wish to edit using the A1 to A4 buttons on the bottom left hand side of the main screen ( see next image ). 

 

   The following two screenshots describe the management of the merged files. The example below (available in …\ANT_PRO\4.maa,) is the "Multiple 3-band quad" merged with a "VHF Yagi – Uda", and consists of four separate antennas. The highlighted antenna (shown in black) is the Uda-Yagi.



The Adding & Deleting Antennas Function within the Pro version Program:

  • The button is only enabled when the number of merged antennas in the opened *.maa file is < 4. If the opened file already has 4 separate antennas as in the previous quad- Yagi-Uda antenna, then  is disabled because there is no room for the new antenna.
  • After clicking of button, specify which antenna you want to add to the existing model.
  • The button is only enabled  if the current model has 2 or more separate antennas. In the above example the is highlighted and the selected antenna (Uda-Yagi) will be removed.
  • The height of each antenna is taken into account in the merged file when the calculations are performed i.e. each antenna is treated separately.

  

Working with a merged antenna model:

  • View Screen:  all antennas except the one selected, are depicted in blue. If the current box is checked on the view screen then all the calculated antennas currents will become visible.
    • o Antenna Selection Panel (bottom left hand side) is used to select which antenna will be shown in the Geometry Tab, and Wire Edit and Element Edit screens.
  • Geometry   Screen: only shows the wires of the selected antenna on the View Tab. Each geometry line entry is prefixed with an Index number of an active antenna (A1, A2, A3 or A4) i.e. A3/23 (23rd wire of third antenna).
  • Geometry   Screen
    • Antenna Selection Panel (centre right hand side) is used to select which antenna will be shown in the Geometry Tab.
    • The Wire Edit & Element Edit tabs will activate pop-up windows, and each one will only display the selected antenna’s wires or elements.
  • All commands of Main menu and submenu Edit affect only selected antenna.
  • When one of the merged antennas is selected, the corresponding source is activated together with the selected frequency for that antenna.

 

Undo/Redo

  • You can roll back to the previous values of the antenna’s parameters after a calculation by using the Undo button on the tool bar.
  • Undo can only perform after calculating the change to the model; otherwise the feature will be inactive.
  • You can perform a Redo after an Undo to return to the new calculated model. This feature is only active if Undo has been performed first.
  • The number of steps undo-redo is only limited capacity hard drive.
  • The Undo and Redo arrow symbols are shown on the toolbar in the following screenshot.

 

Automatic check of wires

  • The Pro version automatically checks the model prior to executing the calculation. It checks the model for errors: such as the same and / or crossed wires unacceptable in the method of moments.
  • These checks are carried out for all antennas in the combined model.
  • If errors are discovered these are displayed in the information window, which provides a description of the error. The Tab key can be used to move the cursor to the problematic wire.
  • If a few errors, the first specified first, since its elimination - the second, etc.
  • The following screenshot shows an example message for combined antenna model where the 28th wire of the first antenna intersects the 12th wire of the second antenna.

 

Advanced 3D far field window

          This screen displays the 3D far field radiation patterns, and has four main parts:

 

 

Main menu
  • File - general commands.
    •    Save image as – save the graphic area Main picture to a  file *.bmp or *.jpg.
    •    Print – print of the graphic area Main picture.
    •    Close – close the 3D far field window.

     

  • View – control the visibility and location of all objects.
    • Centered plot – center the Main picture graphic image.
    • Antenna – toggle on\off display of the antenna in the Main picture.
    • Antenna position – antenna position's control in the Main picture. This item is only active if the antenna display is turned on (see the previous item):
      • Horizontal – horizontal position:
        • As is – the coordinates X and Y are set as per description of the wires.
        • Centered – the antenna is centered to zero coordinates in the XY plane.
      • Vertical – vertical position:
        • Min height = 0 – selects the lowest point of the antenna to the Z = 0 coordinate.
        • Center of antenna = Z0 – puts the geometric centre of the antenna to the Z = 0 coordinate.
    • Width of the lines – selects of thickness (in pixels) of the antenna  lines.
    • Pattern – displays the 3D direction diagram as a plain surface.
    • Grid – displays 3D far field as a grid with the steps as specified in the menu item Scale > Step of the main grid.
    • Monochrome - selects the color and brightness of the 3D far field antenna image.
    • Monochrome gradient – selects the color of the 3D far antenna image. The brightness is proportional to the antenna gain (Ga).
    • Colors – displays the 3D far field antenna image in variable colors. Color and brightness depend of the antenna gain (Ga). The minimal gain is shown in dark-blue; the maximum gain is shown in light purple.
    • Control panel – toggles the Control panel on/off.

     

  • Scale – setting the scale.
    • ARRL – select the half-logarithmic-dB scale, used by the ARRL, which shows the maximum detail at the expense of compressing minor details.
    • dB – logarithmic scale in dB.
    • Linear – is a relative linear scale , normal to 1 scale.
    • Set min dB – (is only active for the logarithmic (dB) scale) selects the initial value of the logarithmic scale. The maximal scale value is automatically set to the maximum gain.
    • Step of a main grid – selects the step  of the 3D far field grid:
      • Elevation step – selects the elevation angle step (10, 20, 50, 100).
      • Azimuth step – selects the azimuth angle step (10, 20, 50, 100).
      A larger step speeds up the computation of 3D images, but can result in graphical errors. Smaller steps increase the computation time, but provide the greatest accuracy.
  •  

  • Colors – selecting the colors used in the displays.
    • Monochrom gradient – selects the color of the monochrome 3D far field.
    • Reference grid – selects the colors of the additional reference grid. (Reference grid is toggled on and off by the checkbox Ref. grid  on a Control panel.)
    • Background – selects the background color.
    • Slices – selects the color of the selected slices.
    • Cursor – selects the colour of the maker-ball, that can be is positioned anywhere along the slice  (see panel Slice).
    • Coordinate – selects the colors of the coordinate grids and fonts use in the flat projections display mode. This mode is set on panel Slice by checkbox Coordinate.
    • – 3 dB ARRL – selects  the color of the "– 3 dB" curve (select the half-logarithmic-dB scale, used by the ARRL, which shows the maximum detail at the expense of compressing minor details).
    • Axes – selects the color of coordinates' axes.
    • Gradient correction – selects the brightness gradient in the Monochrom gradient mode. This item is only active if selected the mode View > Monochrom gradient is selected.
    • Restore default colors – resets all colors to default.
  •  

  • Font – selects the fonts in the Main picture displayed in the mode of flat 2D sections. This mode is set in the Slice panel by checking the Coordinate.
    • Font – selects the fonts' type and color.
    • dB font size – the font size of the gain scale.
    • Deg font size – the font size of the degrees scale. The font color corresponds the color of the coordinates' nets.
  •  

  • Help
    • Help – embedded help.
    • Online help – online help.

 

Main picture

This is the main area of exposition of all kinds of far fields, coordinates and an antenna.

Controls:

  • Moving the mouse with the left button depressed rotates the image.
  • Moving the mouse with the left button depressed + Shift key moves the image linearly.
  • Popup menu (activated by the right mouse click) duplicates the following commands of the Main menu:

 

Control panel

This is the bottom panel with the display controls for he image in the  Main picture.

The panel includes:

  • Checkbox Pattern – toggles the 3D far field image displayed in the Main picture on/off.
  • Checkbox Ref. grid – toggles secondary reference grid with 100 step on/off . It is only active if the 3D far field display by plain surface View > Pattern is turned On.
  • Checkbox Slice – toggles the Slice panel on/off.
  • Trackbar Zoom – selects the amount of zoom in the  Main picture.
  • Panel Field – selects the type of field:
    • V – only vertical polarization.
    • H – only horizontal polarization.
    • Total – antenna’s total (V+H) fields.

 

Slice panel

This is control panel on the left hand side and is activated by the checkbox  Slice on the Control panel.

The panel includes:

  • Checkbox Elevation – toggles the display of a flat vertical slice on/off.
  • Checkbox  Azimuth – toggles the display of conical horizontal slice on/off.
  • Horizontal slider control selects the azimuth angle of the slice
    • in Elevation mode it selects the azimuth angle, of the 3D image for displaying the vertical slice.
    • in Azimuth mode it controls the position of the cursor (red sphere) on the conical horizontal slice.
    The position of the slider control indicates the position of the slice. In the figure above the slide is set to 1600.
  • Cursor – cursor position indicates the value of a current gain. In the figure above the display shows "cursor 3,4 dBi."
  • Vertical slider controls the zenith angle of the slice
    • in Elevation mode selects the position of the cursor (red sphere) on the flat 2D vertical slice.
    • in Azimuth mode selects the elevation angle used for the construction of a conical horizontal slice.
    Adjacent to the vertical slider is a value corresponding to the current position of the slider. In the figure above the position is 1300.
  • Checkbox Coordinate – toggles the "footprint" display for the antenna  on/off  as shown on the picture below.

 

Near field window

          This screen  displays the near field radiation, and has four main parts:

 

Main menu
  • File - general commands.
    •    Open – open the *.nfd and *.csv near field files.
    •    Save – save the *.nfd near field file.
    •    Save image as – save the graphic area Main picture to a  file *.bmp.
    •    NFClose – close the near field window.

     

  • View – control the visibility and location of all objects.
    • 3D Pattern – displays the 3D near field diagram as a surface.
    • 3D Grid – displays 3D near field diagram as a grid.
    • 2D Pattern – displays the 2D near field diagram as a surface.
    • Pattern – on/off the near field diagram.
    • Coordinate – on/off the coordinate grids – on/off the near field diagram.
    • Scale of colors – on/off the scale of colors (left).
    • Reference grid – on/off the grid on the near field diagram.
    • Digits on the grid – on/off the digits on the coordinate grid

     

  • Scale – setting the scale.
      dB – logarithmic scale in dB.
    • Linear – is a relative linear scale.
    • dBuV – logarithmic scale to 1 uV (0 dBuV = 1 uV).
    • Normalized / Auto – in linear mode only. Normal to 1 scale (relative maximum). The maximal scale value is automatically set to the absolute maximum.
      Auto off:


      Auto on:

    • Selected slice –The maximal scale value is automatically set to the maximum of the selected slice.
      Selected slice off:


      Selected slice on:

  •  

  • Colors – selecting the colors used in the displays.
    • Background – selects the background color.
    • Slices – selects the color of the selected X and Y slices.
    • 3D coordinate – selects the colors of the coordinate grid.
    • Reference grid – selects the colors of the grid on the near field diagram.
    • Scale – selects the colors of the scale of color.
  •  

  • Setup
    • 3D Font – selects the 3D fonts' type and color.
    • Color – selects the axes X, Y, Z color.
    • 2D Font – selects the 2D fonts' type and color.
    • Language – selects language.
  •  

  • Help
    • Online – online help.

 

Main picture

This is the main area of exposition of all kinds of near fields and coordinates .

Controls:

  • Moving the mouse with the left button depressed rotates the image.

 

Control panel

This is the bottom panel with the display controls for he image in the  Main picture.

The panel includes:

  • Panel Scale – selects the db, Lin or dBuV scale.
  • Panel Field – selects the type of field: E or H.
  • Trackbar Zoom – selects the amount of zoom in the Main picture.
  • ListPower – selects the power in antenna.
  • Checkbox Slice – toggles the Slice panel on/off.
  • Checkbox 2D – selects 2D view as:

  • Button Calculate – call the setup of the calculations window:

    • Start - the start points of the calculation on the X, Y, Z coordinates.
    • Stop - the end points of the calculation on the X, Y, Z coordinates.
    • Steps - number of the steps between start and and points.
    • Panel Field – selects the calculation type of field: E, H or E and H together.
    • OK - start of the calculations.

 

Slice panel

This is control panel on the left hand side and is activated by the checkbox Slice on the Control panel.

The panel includes:

  • Checkbox Normalized / Auto – in linear mode only. Normal to 1 scale (relative maximum). The maximal scale value is automatically set to the absolute maximum.
    Auto off:


    Auto on:

  • Checkbox Selected slice –The maximal scale value is automatically set to the maximum of the selected slice.
    Selected slice off:


    Selected slice on:

  • Checkbox Flat – selects tha flat view as shown on the picture below.
  • Trackbar X – move X-slice on the diagramm. The position of the slider control indicates the position of the slice.
  • Trackbar Y – move Y-slice on the diagramm. The position of the slider control indicates the position of the slice.
  • Trackbar Z – move Z-slice on the diagramm. The position of the slider control indicates the position of the slice.

 


Compatibility of versions

  • Basic version of MMANA-GAL program can open *.maa PRO files only if the number of wires, segments, loads and sources is within limitations of basic version.
  • Basic version of program will open merged antennas *.maa PRO files as a single one antenna.


LIMITATIONS

  • The authors will only provide program support for registered users, and only answer queries relating to the users version of software, and try to resolve any software problems, and from time to time provide updates for the registered version of the program.
  •  The authors cannot provide any advice or consultancy relating to specific antenna design or for any associated hardware.
  •  The authors do not give any guarantees and shall not be liable for any indirect, special, incidental, or consequential damages (including damages for loss of business profits or goodwill, business interruption or loss of business information), resulting from any defect in the software whether foreseeable or not, arising out of the use or inability to use the Product. In particular, the authors shall have no liability for any loss of data stored in or used with the author’s software, including the cost of recovering such data.
  •  It is illegal under international law to reverse engineer, decompile, disassemble or otherwise reduce the Software to any human readable or perceivable form , or to make any copies of the software without first obtaining approval and licensing for users to make copies of the software. Such activities will result in the immediate canceling of any support and result in legal proceedings being taken against the person(s) in a court of law.

 

Edited by G8ODE

GAL-ANA